Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Carriers around the world are experiencing capacity issues because of increased demand on their networks due to COVID-19. This may result in voice quality issues, busy signals, or other errors on your phone calls. Twilio continues to monitor the health of the global carrier networks and we are publishing the most up-to-date information on our Worldwide Telephony Network Congestion page.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Missing TaskRouter Events that impact Flex Teams View & TaskRouter Statistics API
Incident Report for Twilio
Resolved
The issue was resolved and the service is back to the normal state.
Posted Mar 27, 2020 - 08:53 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 26, 2020 - 17:33 PDT
Identified
At 12:07 pm PDT on 2020-03-25 a deployment created an issue that prevented the generation of 6% of TaskRouter events. These events are consumed by two systems:
1) A system that powers the Flex Teams Dashboard
2) A system that powers TaskRouter’s Cumulative Statistics API
This deployment was rolled back at 12:17 pm PDT on 2020-03-25 that restored the event publishing. Some Flex Tasks or Workers that missed an event during the affected window and haven’t had any updates since that time may show an incorrect status on the Flex Teams Dashboard. We are currently investigating a resolution for the Teams view that is showing stale data.
Posted Mar 26, 2020 - 16:00 PDT
Update
We are continuing to investigate this issue.
Posted Mar 26, 2020 - 15:12 PDT
Investigating
Our monitoring systems have detected a potential issue regarding Taskrouter and Flex. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Mar 26, 2020 - 15:03 PDT
This incident affected: FLEX (TaskRouter, Flex Application Platform).