Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays to Multiple Network In Mexico Over A Subset Of Pre-Registered Sender ID
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS delivery delays to multiple network in Mexico when sending messages over a subset of pre-registered sender IDs. This incident has been resolved.
      Posted Jan 30, 2023 - 23:28 PST
      Update
      We are continuing to observe recovery in SMS delivery delays to multiple network in Mexico when sending messages over a subset of pre-registered sender IDs. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Jan 30, 2023 - 21:28 PST
      Monitoring
      We are observing recovery in SMS delivery delays to multiple network in Mexico when sending messages over a subset of pre-registered sender IDs. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Jan 30, 2023 - 19:28 PST
      Update
      We continue to experience SMS delivery delays to multiple network in Mexico when sending messages over a subset of pre-registered sender IDs. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Jan 30, 2023 - 17:40 PST
      Investigating
      We are experiencing SMS delivery delays to multiple network in Mexico when sending a subset of pre-registered sender IDs. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Jan 30, 2023 - 16:54 PST
      This incident affected: PROGRAMMABLE MESSAGING (SMS).