Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS delivery delayed to US carriers from toll free numbers
Incident Report for Twilio
Resolved
We have confirmed that the issue regarding delayed SMS delivery to US carriers from toll free numbers is now resolved.
Posted 2 months ago. Feb 13, 2019 - 12:23 PST
Monitoring
We are observing recovery in regards to delays of SMS delivery to US carriers from toll free numbers. Our engineering teams will continue to monitor the service.
Posted 2 months ago. Feb 13, 2019 - 11:14 PST
Investigating
We have detected an issue with delayed SMS delivery to all US carriers from toll free numbers. We continue to investigate and work with our partners on a resolution. We will provide an update when we have further information.
Posted 2 months ago. Feb 13, 2019 - 09:57 PST
This incident affected: CARRIER NETWORK (SMS Toll-Free, North America).