Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Report Delays to US Networks from a Small Subset of Twilio US Short Codes
Incident Report for Twilio
Resolved
We are no longer experiencing SMS delivery report delays when sending messages to US networks from Twilio US short codes. This incident has been resolved.
Posted Dec 01, 2021 - 09:52 PST
Monitoring
We are observing recovery in delivery report delays when sending to US networks from Twilio US short codes. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Dec 01, 2021 - 07:58 PST
Update
We are experiencing SMS delivery report delays when sending messages to US networks from a small subset of Twilio US short codes. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Dec 01, 2021 - 07:34 PST
Investigating
Our monitoring systems have detected a potential issue with SMS delivery report delays for a small subset US short codes. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Dec 01, 2021 - 07:23 PST
This incident affected: CARRIER NETWORK (SMS Short Code, North America, SMS Delivery Notifications & Status Callbacks).