Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Programmable Wireless SIM Updates Delayed
Incident Report for Twilio
Resolved
We are no longer experiencing issues with activating new or updating already active Programmable Wireless SIMs. This incident has been resolved.
Posted Feb 22, 2021 - 18:04 PST
Update
Transactions at the downstream connectivity partner are being processed again. Some transactions may still be delayed as queued up transactions are handled. Engineers are continuing to monitor until transaction levels return to normal. Programmable Wireless SIMs that were stuck in `scheduled` or `updating` should be proceeding to their intended states and can be updated again if needed.
Posted Feb 22, 2021 - 16:37 PST
Monitoring
Transactions at the downstream connectivity partner are being processed again. Some transactions may still be delayed as queued up transactions are handled. Engineers are continuing to monitor until transaction levels return to normal. Programmable Wireless SIMs that were stuck in `scheduled` or `updating` should be proceeding to their intended states and can be updated again if needed.
Posted Feb 22, 2021 - 14:43 PST
Identified
Programmable Wireless downstream connectivity partner is experiencing issues with activating new SIMs or updating already active SIMs. Programmable Wireless SIMs for which there are pending updates to the SIM's status or Rate Plan will be stuck in `scheduled` or `updating` until the issue is resolved. You can still submit an update for Programmable Wireless SIMs in other states (e.g. active, new) but they may not complete until the issue at the downstream provider is resolved.

The alert in Console at https://twilio.com/console/wireless/sims indicates an expected end time that is erroneous. Please ignore that. We apologize for any confusion. We expect to provide another update in 60 minutes or as soon as more information becomes available.
Posted Feb 22, 2021 - 14:15 PST
Investigating
Our monitoring systems have detected a potential issue with Programmable Wireless SIMs provisioning for T-mobile. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Feb 22, 2021 - 13:47 PST
This incident affected: INTERNET OF THINGS (Programmable Wireless).