Status
Welcome to the Twilio status page. Here you will find real-time information about status of our services.
Delays in International Outbound SMS Delivery
Incident Report for Twilio
Resolved
Affected destinations have recovered and new messages are being delivered without delay. All delayed messages have been delivered and systems are operating normally.
Posted 22 days ago. Nov 17, 2018 - 07:04 PST
Monitoring
From 05:17am to 06:04am PST, messages sent to international destinations were being processed with a delay. As of 06:05am PST messages sent to international destinations are being delivered without delay.
Posted 22 days ago. Nov 17, 2018 - 06:23 PST