Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Voice Calls Quality Degradation to Some Israel Networks
Incident Report for Twilio
Resolved
The issue affecting degraded performance for calls to Israel has been resolved, and the service is functioning normally at this time.
Posted Jun 06, 2021 - 18:30 PDT
Monitoring
We have seen recovery for inbound calls to Israel for the last 3 hours. We will continue to monitor to ensure a full recovery. We expect to provide another update in 30 minutes or as soon as more information becomes available.
Posted Jun 06, 2021 - 18:00 PDT
Update
We are still observing degraded performance for calls to Israel. We are seeing a number of symptoms including call failures, issues with caller ID, and poor audio quality. We are currently working with our carrier partner to resolve the issue. We expect to provide another update in 4 hours or as soon as more information becomes available.
Posted Jun 06, 2021 - 16:21 PDT
Update
We are still observing degraded performance for calls to Israel. We are seeing a number of symptoms including call failures, issues with caller ID, and poor audio quality. We are currently working with our carrier partner to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Jun 06, 2021 - 14:18 PDT
Update
We are observing degraded performance for calls to Israel. We are seeing a number of symptoms including call failures, issues with caller ID, and poor audio quality. We are currently working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Jun 06, 2021 - 13:22 PDT
Investigating
We've become aware of a potential issue with degraded calls to Israel. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Jun 06, 2021 - 13:06 PDT
This incident affected: CARRIER NETWORK (Voice, Middle East & Africa).