Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Zipwhip Gateway
      Issues related to Zipwhip's Services
        Scheduled maintenance
        System Metrics

        Call Failures to a subset of Twilio's Numbers in Mexico

        Incident Report for Twilio

        Resolved

        On July 29, 2025, Twilio Voice experienced call failures in Mexico from 6:46 AM to 10:52 AM PT. Some customers calling between certain numbers within Mexico were impacted. The issue is now resolved.
        Posted Jul 30, 2025 - 09:22 PDT

        Monitoring

        Our engineers are currently investigating the customer impact of a retroactive issue with Programmable Voice . We will follow up and provide customer impact details within 2 hours.
        Posted Jul 30, 2025 - 08:49 PDT
        This incident affected: CARRIER NETWORK (Voice, Latin America).