Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Delays sending and receiving MMS Messages on US Long Codes
Incident Report for Twilio
Resolved
MMS delays have been resolved and all queues have drained. MMS delivery latency has returned to normal.
Posted 6 months ago. Nov 02, 2018 - 20:45 PDT
Update
We are still seeing delays with MMS message delivery and continuing to work to resolve the issue.
Posted 6 months ago. Nov 02, 2018 - 17:00 PDT
Update
We are still seeing delays sending and receiving MMS messages on US long codes. Our engineers are continuing to work to resolve the issue.
Posted 6 months ago. Nov 02, 2018 - 12:01 PDT
Identified
We have detected delays sending and receiving MMS messages on US long codes. Our engineers are currently investigating.
Posted 6 months ago. Nov 02, 2018 - 10:48 PDT
This incident affected: PROGRAMMABLE MESSAGING (MMS).