Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS and Shortcode delivery delays to T-Mobile and Metro PCS handsets in the US
Incident Report for Twilio
Resolved
We have confirmed that shortcode message delivery to T-Mobile and Metro PCS handsets in the US has recovered.
Posted 5 months ago. Sep 12, 2018 - 10:46 PDT
Investigating
We are experiencing delivery delays for a percentage of messages and shortcodes sent to T-Mobile and Metro PCS handsets in the US. We are working with our carrier partner to resolve and will provide an update as quickly as possible.
Posted 5 months ago. Sep 12, 2018 - 09:28 PDT
This incident affected: CARRIER NETWORK (SMS Short Code, North America) and PROGRAMMABLE MESSAGING (SMS).