Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Report Delays when sending to Etisalat and du Network In United Arab Emirates
      Incident Report for Twilio
      Resolved
      We are no longer experiencing delays in receiving message delivery reports when sending to Etisalat and du Network In United Arab Emirates. This incident has been resolved.
      Posted May 13, 2022 - 12:46 PDT
      Investigating
      We are experiencing SMS delivery delays receiving message delivery reports when sending to Etisalat and du Network In United Arab Emirates. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hours or as soon as more information becomes available.
      Posted May 13, 2022 - 12:41 PDT
      Monitoring
      We are observing recovery in delivery report delays when sending to Etisalat and du Network in United Arab Emirates . We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted May 13, 2022 - 10:35 PDT
      Update
      We continue to experience delays in receiving message delivery reports when sending to Etisalat and du Network in United Arab Emirates. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 4 hours or as soon as more information becomes available.
      Posted May 13, 2022 - 06:44 PDT
      Update
      We are still experiencing delays in receiving message delivery reports when sending to Etisalat and du Network In United Arab Emirates . Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted May 13, 2022 - 04:55 PDT
      Investigating
      We are experiencing delays in receiving message delivery reports when sending to Etisalat and du Network In United Arab Emirates . Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted May 13, 2022 - 03:59 PDT
      This incident affected: CARRIER NETWORK (SMS Delivery Notifications & Status Callbacks).