Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Outbound Shortcode MMS Delivery Failures
Incident Report for Twilio
Resolved
We are no longer observing delivery failure for MMS messages sent to US Carriers from a small subset of shortcodes. This incident has been resolved.
Posted Nov 11, 2020 - 09:58 PST
Monitoring
We are observing recovery for MMS messages sent to US Carriers from a small subset of shortcodes. We will continue monitoring the service to ensure full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Nov 11, 2020 - 08:31 PST
Update
We are observing delivery failures over a subset of shortcodes for MMS messages sent outbound from Twilio. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Nov 11, 2020 - 07:39 PST
Investigating
Our monitoring systems have detected a potential issue with shortcode MMS delivery failure. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Nov 11, 2020 - 07:26 PST
This incident affected: CARRIER NETWORK (MMS Short Code, North America).