Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays and Failures in Qatar - Oredoo
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS delivery delays and failures in Qatar - Oredoo. This incident has been resolved.
      Posted Aug 03, 2022 - 16:33 PDT
      Monitoring
      We are observing successful SMS delivery delays and failures in Qatar - Oredoo. We will continue to monitor to ensure full service recovery. We expect to provide another update in 2 hours or as soon as more information becomes available.
      Posted Aug 03, 2022 - 14:44 PDT
      Update
      We continue experiencing SMS delivery delays and failures in Qatar - Oredoo. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 4 hours or as soon as more information becomes available.
      Posted Aug 03, 2022 - 11:56 PDT
      Update
      We are experiencing SMS delivery delays and failures in Qatar - Oredoo. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Aug 03, 2022 - 10:13 PDT
      Investigating
      We are experiencing SMS delivery delays and failures in Qatar - Oredoo. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Aug 03, 2022 - 09:29 PDT
      This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).