Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
T-Mobile US - SMS Carrier Maintenance - 19 May 2019, 23:00 - 20 May 2019 03:00 (PDT)
Scheduled for May 19, 23:00 PDT  -  May 20, 03:00 PDT
Update
We will be undergoing scheduled maintenance during this time.
Posted 2 days ago. May 16, 2019 - 22:12 PDT
Scheduled
The T-Mobile network in the US will be conducting planned maintenance on their SMS platform on Sunday, 19 May 2019 23:00 - 20 May 2019 03:00 (PDT). During this maintenance window, customers may experience intermittent delays for SMS sent to and from T-Mobile US handsets over Twilio US Toll-free, Twilio long codes, and subset of Twilio US short codes.
Posted 2 days ago. May 16, 2019 - 22:11 PDT
This scheduled maintenance affects: CARRIER NETWORK (SMS Long Code, North America, SMS Short Code, North America, SMS Toll-Free, North America).