Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays to Multiple Networks in US Over a Subset of Toll Free and Short Code
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS delivery delays to multiple networks in USA over a subset of Toll Free and Short Codes. This incident has been resolved.
      Posted May 16, 2024 - 09:58 PDT
      Monitoring
      We have started seeing recovery for the issue causing message delays when sending messages to multiple networks in USA over a subset of Toll Free and Short Code. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted May 16, 2024 - 07:58 PDT
      Update
      We are continuing to experience SMS delivery delays when sending messages to multiple networks in USA over a subset of Toll Free and Short Code. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 8 hours or as soon as more information becomes available.
      Posted May 16, 2024 - 03:21 PDT
      Update
      We are experiencing SMS delivery delays when sending messages to multiple networks in USA over a subset of Toll Free and Short Code. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 4 hours or as soon as more information becomes available.
      Posted May 15, 2024 - 23:29 PDT
      Update
      We are experiencing SMS delivery delays when sending messages to multiple networks in USA over a subset of Toll Free and Short Code. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted May 15, 2024 - 21:25 PDT
      Investigating
      We are experiencing SMS delivery delays when sending messages to multiple networks in USA over a subset of Toll Free and Short Code. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted May 15, 2024 - 20:25 PDT
      This incident affected: CARRIER NETWORK (SMS Short Code, North America, SMS Toll-Free, North America).