Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Multi-product Outage, Webhook Requests are Failing
      Incident Report for Twilio
      Resolved
      All services impacted by the issue with Twilio Rest API impacting multiple Twilio services have recovered and are operating as intended. Twilio Serverless, Studio, Functions, Flex, Messaging, Verify, Programmable Video and Voice services are now working normally and this incident has been resolved.
      Posted Mar 28, 2022 - 09:40 PDT
      Monitoring
      We are observing recovery with the Twilio Rest API issue impacting multiple Twilio services including Serverless, Studio, Functions, Flex, Messaging, Verify, Programmable Video and Voice. We will be monitoring all services to ensure a full recovery and provide another update in 30 minutes or as soon as more information becomes available.
      Posted Mar 28, 2022 - 09:08 PDT
      Update
      We are continuing our investigation and have discovered Programmable Messaging is also affected by this outage.
      Posted Mar 28, 2022 - 08:49 PDT
      Update
      We are continuing our investigation and have discovered Programmable Video is also affected by this outage.
      Posted Mar 28, 2022 - 08:47 PDT
      Identified
      We are experiencing an issue with the Twilio Rest API, impacting multiple Twilio services including Serverless, Studio, Functions, Flex, Messaging, Verify, Programmable Video and Voice. Our engineering team has identified the issue and is actively working to resolve it. We expect to provide another update in 30 mins or as soon as more information becomes available.
      Posted Mar 28, 2022 - 08:36 PDT
      Investigating
      Our monitoring systems have detected a potential issue with our serverless products. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Mar 28, 2022 - 08:15 PDT
      This incident affected: PROGRAMMABLE VOICE (PSTN, SIP Interface, Client Web, Client Mobile, Conference), SERVERLESS (Studio, Functions, Assets, TwiML Bins, Sync), PROGRAMMABLE VIDEO (Group Rooms, Peer-to-Peer Rooms), FLEX (Flex Application Platform), and PROGRAMMABLE MESSAGING (MMS, SMS, Conversations).