Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Client Timeout Errors for Sync, Flex, Programmable Chat, and Conversations
Incident Report for Twilio
Resolved
Twilio Services Sync, Flex, Programmable Chat, and Conversations were degraded for 2 hours 47 minutes between 9:20 AM and 12:07 PM Pacific Time on 02/23/2021. During this period, new clients may have experienced timeout errors when connecting, and existing clients may have experienced timeout errors when reconnecting.The issue has now been resolved.
Posted Feb 23, 2021 - 12:57 PST
Monitoring
The issue causing elevated latency and timeout errors impacting the following Twilio services: Sync, Flex, Programmable Chat, and Conversations has been corrected. We will continue to monitor for system stability. We'll provide another update in 60 minutes or as soon as more information becomes available.
Posted Feb 23, 2021 - 12:12 PST
Identified
We have identified the issue causing elevated latency and timeout errors impacting the following Twilio services: Sync, Flex, Programmable Chat, and Conversations. New clients may experience timeout errors when connecting, and existing clients may experience timeout errors when reconnecting. Our engineering team is actively working on mitigating the issue, and we will provide another update in 60 minutes or as soon as more information becomes available.
Posted Feb 23, 2021 - 11:24 PST
Update
We are currently investigating elevated latency and timeout errors impacting the following Twilio services: Sync, Flex, Programmable Chat, and Conversations. New clients may experience timeout errors when connecting, and existing clients may experience timeout errors when reconnecting. Our engineering team is actively working on diagnosing and mitigating the issue, and we will provide another update in 60 minutes or as soon as more information becomes available.
Posted Feb 23, 2021 - 10:57 PST
Update
We are currently investigating elevated latency and timeout errors impacting the following Twilio services: Sync, Flex, Programmable Chat, and Conversations. Customers may experience client timeout errors.. Our engineering team is actively working on the issue, and we will provide another update in 30 minutes or as soon as more information becomes available.
Posted Feb 23, 2021 - 10:35 PST
Update
We are currently investigating elevated latency and timeout errors impacting the following Twilio services: Sync, Flex, Programmable Chat, and Conversations. Customers may experience client timeout errors.. Our engineering team is actively working on the issue, and we will provide another update in 30 minutes or as soon as more information becomes available.
Posted Feb 23, 2021 - 10:28 PST
Investigating
Our monitoring systems have detected a potential issue with mobile SDKs accessing Programmable Chat services. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Feb 23, 2021 - 10:21 PST
This incident affected: FLEX (Flex Application Platform), SERVERLESS (Sync), PROGRAMMABLE CHAT, and PROGRAMMABLE MESSAGING (Conversations).