Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Failures on Airtel in Nigeria
      Incident Report for Twilio
      Resolved
      We are no longer experiencing delivery failures on Airtel in Nigeria. This incident has been resolved.
      Posted Feb 24, 2020 - 06:50 PST
      Monitoring
      We are observing successful delivery on Airtel in Nigeria for the last 15 minutes. We will continue to monitor to ensure a full recovery.
      Posted Feb 24, 2020 - 06:16 PST
      Investigating
      We are experiencing SMS delivery failures to Airtel in Nigeria. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
      Posted Feb 24, 2020 - 05:49 PST