Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Inaccurate Lookups API Results for a Subset of Numbers in Jamaica and Barbados (+1876 and +1246)
      Incident Report for Twilio
      Resolved
      Our engineers have deployed a fix. We are no longer experiencing inaccurate Lookups API results for numbers in Jamaica and Barbados (+1876 and +1246). This incident has been resolved.
      Posted Jun 05, 2020 - 18:12 PDT
      Identified
      We have identified an issue with inaccurate Lookup API results for a subset of numbers in Jamaica and Barbados (+1876 and +1246). We are actively working to resolve the issue and will provide an update when this is completed.
      Posted Jun 05, 2020 - 17:35 PDT
      Update
      We are continuing to investigate this issue.
      Posted Jun 05, 2020 - 17:06 PDT
      Update
      We are continuing to investigate this issue.
      Posted Jun 05, 2020 - 17:05 PDT
      Investigating
      Our monitoring systems have detected a potential issue. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Jun 05, 2020 - 17:01 PDT
      This incident affected: ACCOUNT SECURITY (Lookup).