Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Our Engineers are Investigating a Problem with Provisioning Phone Numbers and Creating Addresses from Console and REST API
Incident Report for Twilio
Resolved
We have implemented a fix for phone number provisioning and the service is stable. The incident is resolved.

If you have a Phone Number with a status of Reserved the number will be recovered by Twilio. Please purchase a new number.

Thank You
Posted Mar 29, 2021 - 08:22 PDT
Monitoring
We have implemented a fix for phone number provisioning and are continuing to monitor for service stability. Another update will be provided in 1 hour or as soon as more information becomes available.
Posted Mar 29, 2021 - 07:14 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 29, 2021 - 07:01 PDT
Update
We are continuing to investigate this issue.
Posted Mar 29, 2021 - 06:56 PDT
Update
Our engineers are investigating a problem with creating addresses, buying phone numbers and uploading regulatory documents, through the console and REST API, we are expecting to provide an update in 1 hour or as soon as more information becomes available.
Posted Mar 29, 2021 - 05:48 PDT
Update
Our engineers are investigating a problem with creating addresses and provisioning phone numbers with addresses from the console and REST API, we are expecting to provide an update in 30 minutes or as soon as more information becomes available.
Posted Mar 29, 2021 - 05:20 PDT
Investigating
Our monitoring systems have detected a potential issue with creating addresses for non-US phone numbers. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Mar 29, 2021 - 05:07 PDT
This incident affected: PHONE NUMBERS and TWILIO PLATFORM (Console, REST API).