Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
MMS Delivery Delays When Sending to the US From a Subset of Twilio Short Codes
Incident Report for Twilio
Resolved
We are no longer experiencing delivery delays when sending MMS from Twilio US Shortcodes to US carriers. This incident has been resolved.
Posted Sep 25, 2020 - 15:24 PDT
Monitoring
We are no longer seeing MMS delays from Twilio US Shortcodes to US Carriers for the last 10 minutes. We will continue to monitor to ensure full service recovery. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Sep 25, 2020 - 14:15 PDT
Update
We continue to experience MMS delivery delays from a small subset of Twilio US Shortcodes to US carriers. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Sep 25, 2020 - 12:22 PDT
Update
We are experiencing MMS delivery delays from a small subset of US Shortcodes to US carriers. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Sep 25, 2020 - 11:22 PDT
Investigating
Our monitoring systems have detected a potential issue with US Shortcode MMS delays to a small subset of customers. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Sep 25, 2020 - 11:17 PDT
This incident affected: CARRIER NETWORK (MMS Short Code, North America).