Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Delays in Billing and Usage API
      Incident Report for Twilio
      Resolved
      Billing and Usage API are operating normally.
      Posted Sep 21, 2015 - 17:06 PDT
      Identified
      We continue working on resolving the delay in billing and usage services. We expect to clear the built up queue by 4pm PT today.
      Posted Sep 21, 2015 - 15:12 PDT
      Investigating
      We are experiencing delays up to 20 minutes in updating billing and usage information in Account Portal and Usage API. Price for calls and messages will be marked TBD, usage may not show up-to-date aggregate usage in Account Portal. Usage API may not have the an up-to-date count for a usage category. The price will accurately reflect the usage count shown. Our engineering team is working on resolving this delay as soon as possible.
      Posted Sep 21, 2015 - 12:46 PDT
      This incident affected: TWILIO PLATFORM (Billing).