Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS delivery delays to Megafon handsets in Russia
Incident Report for Twilio
Resolved
This incident has been resolved.
Posted about 1 month ago. Aug 20, 2019 - 09:19 PDT
Monitoring
We are currently observing a recovery for SMS delivery delays to Megafon handsets in Russia. Our teams will continue to monitor the service and we will provide an update as soon as we have more information.
Posted about 1 month ago. Aug 20, 2019 - 08:06 PDT
Investigating
We are observing SMS delivery delays to Megafon handsets in Russia. We are actively working with our carrier partner to resolve the issue. We will provide an update as soon as possible.
Posted about 1 month ago. Aug 20, 2019 - 06:50 PDT
This incident affected: CARRIER NETWORK (SMS, Europe).