We have fully investigated the Sender ID issue triggered by our automated alert, and it was determined that there is no noticeable customer impact. All systems are operational.
Posted May 13, 2025 - 15:06 PDT
Update
Our engineers are continuing to investigate the customer impact of a retroactive issue with Sender ID. We will follow up and provide customer impact details within 16 hours or sooner.
Posted May 13, 2025 - 13:55 PDT
Update
Our engineers are continuing to investigate the customer impact of a retroactive issue with Sender ID. We will follow up and provide customer impact details within 8 hours.
Posted May 12, 2025 - 19:59 PDT
Update
Our engineers are continueing to investigate the customer impact of a retroactive issue with Sender ID. We will follow up and provide customer impact details within 4 hours.
Posted May 12, 2025 - 15:59 PDT
Monitoring
Our engineers are currently investigating the customer impact of a retroactive issue with Sender ID. We will follow up and provide customer impact details within 2 hours.