Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Delayed Super SIM Connection Events
Incident Report for Twilio
Resolved
The fix has been fully deployed, and we are no longer experiencing connectivity event reporting delays. Our Super SIM service is operating normally at this time.
Posted Jan 10, 2022 - 08:14 PST
Update
The Super SIM team is currently deploying a fix for the identified issue causing delayed reporting of connectivity events. This issue has no impact on the connectivity of Super SIM devices. We will provide another update in 4 hours or sooner once more information becomes available.
Posted Jan 10, 2022 - 07:32 PST
Identified
The Super SIM team has identified an issue with delayed reporting of connectivity events. This issue has no impact on the connectivity of Super SIM devices. We are actively working to resolve the issue. We will provide another update in 2 hours or sooner once more information becomes available.
Posted Jan 10, 2022 - 05:33 PST
Investigating
Our monitoring systems have detected a potential issue with Super SIM. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Jan 10, 2022 - 05:26 PST
This incident affected: INTERNET OF THINGS (Super SIM).