Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Delays to Vala Network in Republic of Kosovo
Incident Report for Twilio
Resolved
Twilio was informed that the intermittent message delivery delays to the Vala Network in Kosovo were caused by a technical problem in the mobile operator’s messaging platform and there is currently no estimated resolution time. As the impact is limited to a small subset of customers, we’ll be marking the incident as closed on StatusPage and continue to update affected customers via email until the incident is fully resolved.
Posted May 07, 2021 - 13:49 PDT
Update
We are still experiencing SMS delivery delays to Vala network in the Republic of Kosovo. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 24 hours or as soon as more information becomes available.
Posted May 06, 2021 - 18:04 PDT
Update
We are still experiencing SMS delivery delays to Vala network in the Republic of Kosovo. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 24 hours or as soon as more information becomes available.
Posted May 05, 2021 - 16:20 PDT
Update
We are still experiencing SMS delivery delays to Vala network in the Republic of Kosovo. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 16 hours or as soon as more information becomes available.
Posted May 04, 2021 - 23:30 PDT
Update
We are still experiencing SMS delivery delays to Vala network in the Republic of Kosovo. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 8 hours or as soon as more information becomes available.
Posted May 04, 2021 - 15:30 PDT
Update
We are still experiencing SMS delivery delays to Vala network in the Republic of Kosovo. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 4 hours or as soon as more information becomes available.
Posted May 04, 2021 - 11:20 PDT
Update
We are still experiencing SMS delivery delays to Vala network in Republic of Kosovo. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
Posted May 04, 2021 - 09:21 PDT
Update
We are experiencing SMS delivery delays when sending messages to Vala network in the Republic of Kosovo. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted May 04, 2021 - 08:41 PDT
Investigating
Our monitoring systems have detected a potential issue with SMS delivery delays to Vala network in Republic of Kosovo. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted May 04, 2021 - 08:23 PDT
This incident affected: CARRIER NETWORK (SMS, Europe).