Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Zipwhip Gateway
      Issues related to Zipwhip's Services
        Scheduled maintenance
        System Metrics

        Delays in Retrieving Some Historical Messaging Data

        Incident Report for Twilio

        Resolved

        All historical data about messages that are requested via the Console or API is now up to date, and all queued information about messages have been processed. The service is operating normally at this time.
        Posted Nov 24, 2023 - 01:24 PST

        Monitoring

        All historical data about messages that are requested via the Console or API is now up to date, and all queued information about messages have been processed. We are monitoring the service to ensure a full recovery, and we will provide another update in 2 hours or as soon as more information becomes available.
        Posted Nov 23, 2023 - 23:09 PST

        Update

        For customers who are requesting historical data about messages that have been sent during the past 7 hours via the Console or API, there is a small probability that the data could be delayed. The root cause has been identified and eliminated. We have started to process the queued messages and expect to provide another update in 16 hours or as soon as more information becomes available.
        Posted Nov 23, 2023 - 19:40 PST

        Update

        For customers who are requesting historical data about messages, that have been sent during the past 7 hours, via the Console or API, there is a small probability that the data could be delayed. The root cause has been identified and eliminated. We have started to process the queued messages and expect to provide another update in 8 hours or as soon as more information becomes available.
        Posted Nov 23, 2023 - 11:41 PST

        Update

        For customers who are requesting historical data about messages, that have been sent during the past 7 hours, via the Console or API, there is a small probability that the data could be delayed. The root cause has been identified and eliminated. We have started to process the queued messages and expect to provide another update in 4 hours or as soon as more information becomes available.
        Posted Nov 23, 2023 - 07:50 PST

        Update

        For customers who are requesting historical data about messages, that have been sent during the past 7 hours, via the Console or API, there is a small probability that the data could be delayed. The root cause has been identified and eliminated. We have started to process the queued messages and expect to provide another update in 2 hours or as soon as more information becomes available.
        Posted Nov 23, 2023 - 05:41 PST

        Identified

        For customers who are requesting historical data about messages, that have been sent during the past 7 hours, via the Console or API, there is a small probability that the data could be delayed. The root cause has been identified and eliminated. We have started to process the queued messages and expect to provide another update in 1 hour or as soon as more information becomes available.
        Posted Nov 23, 2023 - 04:38 PST

        Update

        For customers who are requesting historical data about messages, that have been sent during the past 7 hours, via the Console or API, there is a small probability that the data could be delayed. We are continuing to investigate this issue and expect to provide another update in 2 hours or as soon as more information becomes available.
        Posted Nov 23, 2023 - 02:36 PST

        Update

        For customers who are requesting historical data about messages, that have been sent during the past 7 hours, via the Console or API, there is a small probability that the data could be delayed. We expect to provide another update in 1 hour or as soon as more information becomes available.
        Posted Nov 23, 2023 - 01:23 PST

        Investigating

        Our monitoring systems have detected a potential issue with message logging. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
        Posted Nov 23, 2023 - 00:47 PST
        This incident affected: PROGRAMMABLE MESSAGING (MMS, SMS).