Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Errors Registering to SDK Clients
      Incident Report for Twilio
      Resolved
      We are no longer experiencing errors registering SDK clients. This incident has been resolved.
      Posted Feb 18, 2022 - 12:00 PST
      Update
      We are observing recovery in registering SDK clients from February 16 at 9:02 PM PT. Rate limits that were applied during the incident mitigation have been removed. We will continue monitoring the service to ensure a full recovery. We will provide another update in 24 hours or as soon as more information becomes available.
      Posted Feb 18, 2022 - 05:11 PST
      Update
      We are observing recovery in registering SDK clients from February 16 at 9:02 PM PT. Rate limits that were applied during the incident mitigation have been removed. We will continue monitoring the service to ensure a full recovery. We will provide another update in 16 hours or as soon as more information becomes available.
      Posted Feb 17, 2022 - 13:11 PST
      Update
      We are observing recovery in registering SDK clients from 9:02 PM PT. Rate limits that were applied during the incident mitigation have been removed , We will continue monitoring the service to ensure a full recovery. We will provide another update in 8 hours or as soon as more information becomes available.
      Posted Feb 17, 2022 - 05:18 PST
      Update
      We are observing recovery in registering SDK clients from 9:02 PM PT. Rate limits that were applied during the incident mitigation have been removed , We will continue monitoring the service to ensure a full recovery. We will provide another update in 8 hours or as soon as more information becomes available.
      Posted Feb 17, 2022 - 05:17 PST
      Update
      We are observing recovery in registering SDK clients from 9:02 PM PT. Rate limits that were applied during the incident mitigation have been removed , We will continue monitoring the service to ensure a full recovery. We will provide another update in 4 hours or as soon as more information becomes available.
      Posted Feb 17, 2022 - 01:17 PST
      Update
      We are observing recovery in registering SDK clients from 9:02 PM PT. However, there are still some rate limits being applied, although retries will eventually succeed. We will continue monitoring the service to ensure a full recovery. We will provide another update in 4 hours or as soon as more information becomes available.
      Posted Feb 17, 2022 - 00:48 PST
      Update
      We are observing recovery in registering SDK clients from 9:02 PM PT. However, there are still some rate limits being applied, although retries will eventually succeed. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Feb 16, 2022 - 22:48 PST
      Monitoring
      We are observing recovery in registering SDK clients from 9:02 PM PT. However, there are still some rate limits being applied, although retries will eventually succeed. We will continue monitoring the service to ensure a full recovery. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Feb 16, 2022 - 21:48 PST
      Update
      We are still observing issues with customers registering SDK clients. Customers may experience 429 and 500 errors due to rate limits, as well as increased latency. Our engineers are actively working on the issue. We expect to provide another update in 2 hour or as soon as more information becomes available.
      Posted Feb 16, 2022 - 20:30 PST
      Update
      We are still observing issues with customers registering new SDK clients. Customers may experience 429 and 500 errors due to rate limits, as well as increased latency. Our engineers are actively working on the issue. We expect to provide another update in 2 hour or as soon as more information becomes available.
      Posted Feb 16, 2022 - 18:30 PST
      Update
      We are still observing issues with customers registering new SDK clients. Customers may experience 429 and 500 errors due to rate limits, as well as increased latency. Our engineers are actively working on the issue. We expect to provide another update in 2 hour or as soon as more information becomes available.
      Posted Feb 16, 2022 - 16:30 PST
      Identified
      We are again observing issues with customers registering new SDK clients. Customers may experience 429 and 500 errors due to rate limits as well as increased latency. Our engineering is actively working on the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Feb 16, 2022 - 15:29 PST
      Monitoring
      We are observing recovery in registering new SDK clients from 2:00 PM PT. We will continue monitoring the service to ensure a full recovery. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Feb 16, 2022 - 14:26 PST
      Update
      We are continuing to observe issues with customers registering new SDK clients. Customers may experience 429/500 errors due to rate limits, as well as increased latency. Our engineering team continues to actively work on the issue. We expect to provide another update in 30 minute or as soon as more information becomes available.
      Posted Feb 16, 2022 - 13:54 PST
      Update
      We are still observing issues with customers registering new SDK clients. Customers may experience 429 errors due to rate limits as well as increased latency. Our engineering is actively working on the issue. We expect to provide another update in 30 minute or as soon as more information becomes available.
      Posted Feb 16, 2022 - 13:24 PST
      Identified
      We are again observing issues with customers registering new SDK clients. Customers may experience 429 errors due to rate limits as well as increased latency. Our engineering is actively working on the issue. We expect to provide another update in 30 minute or as soon as more information becomes available.
      Posted Feb 16, 2022 - 12:49 PST
      Update
      We are observing recovery in registering new SDK clients from 08:29 AM PST. We will still continue to monitor the service to ensure a full recovery. We will provide another update in 4 hours or as soon as more information becomes available.
      Posted Feb 16, 2022 - 12:19 PST
      Update
      We are observing recovery in registering new SDK clients from 08:29 AM PST. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Feb 16, 2022 - 10:19 PST
      Monitoring
      We are observing recovery in registering new SDK clients from 08:29 AM PST. We will continue monitoring the service to ensure a full recovery. We will provide another update in 30 minutes or as soon as more information becomes available.
      Posted Feb 16, 2022 - 09:51 PST
      Update
      We are still observing issues with customers registering new SDK clients from 05:50 AM PST. Customers may experience 429 errors due to rate limits as well as increased latency. Our engineering is still actively working on the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
      Posted Feb 16, 2022 - 08:12 PST
      Identified
      We are again observing issues with customers registering new SDK clients from 13:50 UTC. Customers may experience 429 errors due to rate limits as well as increased latency. Our engineering is actively working on the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Feb 16, 2022 - 07:18 PST
      Update
      We experienced intermittent errors with customers registering to new SDK Clients from 12:48 PM PST to 1:55 PM PST. All impacted services have now recovered and we are continuing to monitor for system stability. We will update in 16 hours or as soon as more information is available.
      Posted Feb 16, 2022 - 05:14 PST
      Update
      We experienced intermittent errors with customers registering to new SDK Clients from 12:48 PM PST to 1:55 PM PST. All impacted services have now recovered and we are continuing to monitor for system stability. We will update in 8 hours or as soon as more information is available.
      Posted Feb 15, 2022 - 21:14 PST
      Update
      We experienced intermittent errors with customers registering to new SDK Clients from 12:48 PM PST to 1:55 PM PST. All impacted services have now recovered and we are continuing to monitor for system stability. We will update in 4 hours or as soon as more information is available.
      Posted Feb 15, 2022 - 17:14 PST
      Monitoring
      We experienced intermittent errors with customers registering to new SDK Clients from 12:48 PM PST to 1:55 PM PST. All impacted services have now recovered and we are continuing to monitor for system stability. We will update in 2 hours or as soon as more information is available.
      Posted Feb 15, 2022 - 15:01 PST
      Update
      We are experiencing an issue with customers registering new SDK clients. Customers may experience 429 errors due to rate limits as well as increased latency. Our engineering is actively working on the issue. We will update in 1 hour or as soon as we have more information.
      Posted Feb 15, 2022 - 14:01 PST
      Investigating
      We've become aware of a potential issue with customers registering new SDK clients. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Feb 15, 2022 - 13:36 PST
      This incident affected: FLEX (Flex Application Platform), SERVERLESS (Sync), and PROGRAMMABLE MESSAGING (Notify, Conversations).