Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 12, 2025 - 01:00 PST
Update
Our carrier partner T-Mobile US United States is conducting a planned maintenance from 12 January 2025 at 01:00 PST until 12 January 2025 at 07:00 PST. During the maintenance window, there could be intermittent API request failures for T-Mobile US United States customers.
Impacted Product: Lookup SIM Swap
Posted Jan 07, 2025 - 04:51 PST
Update
We will be undergoing scheduled maintenance during this time.
Posted Jan 07, 2025 - 04:40 PST
Scheduled
Our carrier partner T-Mobile US United States is conducting a planned maintenance from 12 January 2025 at 01:00 PST until 12 January 2025 at 07:00 PST. During the maintenance window, there could be intermittent API request failures for T-Mobile US United States customers.
Impacted Product: Lookup SIM Swap
Posted Jan 07, 2025 - 04:38 PST
This scheduled maintenance affected: CARRIER NETWORK (Lookup SIM Swap).