The issue affecting Call Failures to Canada for a Subset of Canadian Twilio's Local Numbers has been resolved, and the service is functioning normally at this time.
Posted May 09, 2025 - 15:50 PDT
Update
We continue to see recovery for inbound Call Failures to Canada for a Subset of Canadian Twilio's Local Numbers. We will continue to monitor to ensure a full recovery. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted May 09, 2025 - 13:51 PDT
Monitoring
We have started seeing recovery for inbound Call Failures to Canada for a Subset of Canadian Twilio's Local Numbers. We will continue to monitor to ensure a full recovery. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted May 09, 2025 - 12:00 PDT
Update
We are observing Call Failures to Canada for a Subset of Canadian Twilio's Local Numbers. We are currently working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted May 09, 2025 - 11:17 PDT
Investigating
We are observing Call Failures to Canada for a Subset of Canadian Twilio's Local Numbers. We are currently working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted May 09, 2025 - 11:04 PDT
Identified
We are observing Call Failures to Canada for a Subset of Canadian Twilio's Local Numbers. We are currently working with our carrier partner to resolve the issue. We expect to provide another update in 1 hours or as soon as more information becomes available.
Posted May 09, 2025 - 10:59 PDT
This incident affected: CARRIER NETWORK (Voice, North America).