Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Zipwhip Gateway
      Issues related to Zipwhip's Services
        Scheduled maintenance
        System Metrics
        Call Failures to a Subset of Jamaica Twilio Numbers
        Incident Report for Twilio
        Resolved
        The issue affecting call failures to a Subset of Jamaica Twilio Numbers has been resolved, and the service is functioning normally at this time. This incident has been resolved.
        Posted Jan 15, 2025 - 21:42 PST
        Monitoring
        We have started seeing recovery for calls to a Subset of Jamaica Twilio Numbers. We will continue to monitor to ensure a full recovery. We expect to provide another update in 2 hours or as soon as more information becomes available.
        Posted Jan 15, 2025 - 19:42 PST
        Update
        We are continuing to observe call failures to a Subset of Jamaica Twilio Numbers. We are currently working with our carrier partner to resolve the issue. We expect to provide another update in 4 hours or as soon as more information becomes available.
        Posted Jan 15, 2025 - 15:42 PST
        Update
        We continue to observe call failures to a Subset of Jamaica Twilio Numbers. We are currently working with our carrier partner to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
        Posted Jan 15, 2025 - 13:42 PST
        Investigating
        We are observing call failures to a Subset of Jamaica Twilio Numbers. We are currently working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
        Posted Jan 15, 2025 - 12:42 PST
        This incident affected: CARRIER NETWORK (Voice, North America).