We are no longer experiencing MMS/SMS delivery Report delays when sending messages to multiple networks in the United States of America via a subset of shortcodes.. This incident has been resolved.
Posted Feb 19, 2025 - 13:10 PST
Monitoring
We are observing recovery in delivery report delays when sending messages to multiple networks in the United States of America via a subset of shortcodes. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Feb 19, 2025 - 11:25 PST
Update
We are continuing to investigate this issue.
Posted Feb 19, 2025 - 10:34 PST
Update
We are continuing to investigate this issue.
Posted Feb 19, 2025 - 10:33 PST
Investigating
We are experiencing SMS delivery report delays when sending messages to multiple networks in the United States of America via a subset of shortcodes. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Feb 19, 2025 - 10:30 PST
This incident affected: CARRIER NETWORK (SMS Short Code, North America).