Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Programmable Wireless SIMs are Losing Their Ability to Establish Data Sessions
      Incident Report for Twilio
      Resolved
      We are continuing to explore a long term solution with our connectivity partner to resolve the issue where international (non-US) roaming permissions expire after 1,047 days and need to be re-applied. We are seeking one that does not require you to perform updates to all of your SIMs as doing so will cause them to temporarily disconnect. We expect this solution to take some time (days/weeks) to plan and execute. In the meantime, the workaround described earlier in this incident can help mitigate this issue if you have Programmable Wireless SIMs that have been active for over 2.5 years. Once we have a long term solution, we will send out an advisory email to Programmable Wireless users with more details. If you have been impacted by this incident and wish to continue to receive updates, please open a ticket with customer support.
      Posted Aug 12, 2022 - 17:53 PDT
      Update
      We are continuing to explore a long term solution with our connectivity partner to resolve the issue where international (non-US) roaming permissions expire after 1,047 days and need to be re-applied. We are seeking one that does not require you to perform updates to all of your SIMs as doing so will cause them to temporarily disconnect. We expect this solution to take some time (days/weeks) to plan and execute. In the meantime, the workaround described earlier in this incident can help mitigate this issue if you have Programmable Wireless SIMs that have been active for over 2.5 years. Once we have a long term solution, we will send out an advisory email to Programmable Wireless users with more details. Unless we have material changes to share with you in the next 24 hours we will close the alert on Twilio’s Status Page. If you have been impacted by this incident and wish to continue to receive updates, please open a ticket with customer support.
      Posted Aug 11, 2022 - 17:52 PDT
      Update
      We are continuing to explore a long term solution with our connectivity partner to resolve the issue where international (non-US) roaming permissions expire after 1,047 days and need to be re-applied. We are seeking one that does not require you to perform updates to all of your SIMs as doing so will cause them to temporarily disconnect. We expect this solution to take some time (days/weeks) to plan and execute. In the meantime, the workaround described earlier in this incident can help mitigate this issue if you have Programmable Wireless SIMs that have been active for over 2.5 years. Once we have a long term solution, we will send out an advisory email to Programmable Wireless users with more details. Unless we have material changes to share with you in the next 24 hours we will close the alert on Twilio’s Status Page. If you have been impacted by this incident and wish to continue to receive updates, please open a ticket with customer support.
      Posted Aug 11, 2022 - 17:40 PDT
      Update
      We are continuing to work with our downstream connectivity partner on a long term fix for the issue where Programmable Wireless SIMs that have been deployed for multiple years have their international roaming permissions expire after 1,047 days. In the meantime, if you believe you have been or are at risk of being impacted by this, you can either 1.) update your SIM's status to 'deactivated' and then update it again to 'active' or 2.) create a Rate Plan without international roaming enabled, move your SIMs to that Rate Plan temporarily, then move them back to their original Rate Plan with international roaming enabled. Either of these 2 approaches will remove the international roaming permission and re-apply it, resetting the expiration timer. We will provide another update in 13 hours or as soon as more information becomes available.
      Posted Aug 11, 2022 - 17:11 PDT
      Update
      We are continuing to work with our downstream connectivity partner on a long term fix for the issue where Programmable Wireless SIMs that have been deployed for multiple years have their international roaming permissions expire after 1,047 days. In the meantime, if you believe you have been or are at risk of being impacted by this, you can either 1.) update your SIM's status to 'deactivated' and then update it again to 'active' or 2.) create a Rate Plan without international roaming enabled, move your SIMs to that Rate Plan temporarily, then move them back to their original Rate Plan with international roaming enabled. Either of these 2 approaches will remove the international roaming permission and re-apply it, resetting the expiration timer. We will provide another update in 16 hours or as soon as more information becomes available.
      Posted Aug 11, 2022 - 14:11 PDT
      Update
      The cause for loss of connectivity has been identified. When a SIM is activated certain permissions are assigned to it based on your Rate Plan settings. The permission added by our downstream connectivity partner to a SIM when international roaming is enabled expires after 1,047 days (~2 years and 10 months) from the time the SIM is activated. Deactivating and reactivating the SIM reapplies the permission with a new expiration date 1,047 days in the future. We are continuing to with our partner to see if we can refresh the expiration dates for all of our active SIMs without needing to deactivate and reactivate them. In the meantime, if you have Programmable Wireless SIMs that have been deployed for multiple years that begin to go offline, consider deactivating and reactivating your SIMs to refresh their permissions. We will provide another update in 8 hours or as soon as more information becomes available.
      Posted Aug 11, 2022 - 05:20 PDT
      Update
      The cause for loss of connectivity has been identified. When a SIM is activated certain permissions are assigned to it based on your Rate Plan settings. The permission added by our downstream connectivity partner to a SIM when international roaming is enabled expires after 1,047 days (~2 years and 10 months) from the time the SIM is activated. Deactivating and reactivating the SIM reapplies the permission with a new expiration date 1,047 days in the future. We are continuing to with our partner to see if we can refresh the expiration dates for all of our active SIMs without needing to deactivate and reactivate them. In the meantime, if you have Programmable Wireless SIMs that have been deployed for multiple years that begin to go offline, consider deactivating and reactivating your SIMs to refresh their permissions. We will provide another update in 4 hours or as soon as more information becomes available.
      Posted Aug 11, 2022 - 01:20 PDT
      Update
      The cause for loss of connectivity has been identified. When a SIM is activated certain permissions are assigned to it based on your Rate Plan settings. The permission added by our downstream connectivity partner to a SIM when international roaming is enabled expires after 1,047 days (~2 years and 10 months) from the time the SIM is activated. Deactivating and reactivating the SIM reapplies the permission with a new expiration date 1,047 days in the future. We are continuing to with our partner to see if we can refresh the expiration dates for all of our active SIMs without needing to deactivate and reactivate them. In the meantime, if you have Programmable Wireless SIMs that have been deployed for multiple years that begin to go offline, consider deactivating and reactivating your SIMs to refresh their permissions. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Aug 10, 2022 - 23:20 PDT
      Identified
      The cause for loss of connectivity has been identified. When a SIM is activated certain permissions are assigned to it based on your Rate Plan settings. The permission added by our downstream connectivity partner to a SIM when international roaming is enabled expires after 1,047 days (~2 years and 10 months) from the time the SIM is activated. Deactivating and reactivating the SIM reapplies the permission with a new expiration date 1,047 days in the future. We are working with our partner to see if we can refresh the expiration dates for all of our active SIMs without needing to deactivate and reactivate them. In the meantime, if you have Programmable Wireless SIMs that have been deployed for multiple years that begin to go offline, consider deactivating and reactivating your SIMs to refresh their permissions. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Aug 10, 2022 - 22:20 PDT
      Update
      We continue to experience cases where Programmable Wireless SIMs outside of the United States may suddenly lose connectivity and be unable to reconnect. Attempting to reset the SIM’s connectivity is ineffective. As a workaround, updating the SIM’s status to “deactivated” and then changing it back to “active” will reprovision the SIM. Once reprovisioned, the SIM should be able to reconnect. We have observed some SIMs reconnecting quickly and others may take a couple hours to successfully start new data sessions. SIMs need to be updated back to “active” within 72 hours or a deactivated SIM will automatically transition to canceled and will no longer be available for updates. Our engineering team is actively working with the affected network provider to resolve the issue. We will provide another update in 4 hours or as soon as more information becomes available.
      Posted Aug 10, 2022 - 20:17 PDT
      Update
      We are continuing to experience cases where Programmable Wireless SIMs outside of the United States may suddenly lose connectivity and be unable to reconnect. Attempting to reset the SIM’s connectivity is ineffective. As a workaround, updating the SIM’s status to “deactivated” and then changing it back to “active” will reprovision the SIM. Once reprovisioned, the SIM should be able to reconnect. We have observed some SIMs reconnecting quickly and others may take a couple hours to successfully start new data sessions. SIMs need to be updated back to “active” within 72 hours or a deactivated SIM will automatically transition to canceled and will no longer be available for updates. Our engineering team is actively working with the affected network provider to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Aug 10, 2022 - 18:17 PDT
      Update
      We are experiencing cases where Programmable Wireless SIMs outside of the United States may suddenly lose connectivity and be unable to reconnect. Attempting to reset the SIM’s connectivity is ineffective. As a workaround, updating the SIM’s status to “deactivated” and then changing it back to “active” will reprovision the SIM. Once reprovisioned, the SIM should be able to reconnect. We have observed some SIMs reconnecting quickly and others may take a couple hours to successfully start new data sessions. SIMs need to be updated back to “active” within 72 hours or a deactivated SIM will automatically transition to canceled and will no longer be available for updates. Our engineering team is actively working with the affected network provider to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Aug 10, 2022 - 17:19 PDT
      Investigating
      Our monitoring systems have detected a potential issue with Twilio SIM Cards loosing their ability to establish data sessions. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Aug 10, 2022 - 16:58 PDT
      This incident affected: INTERNET OF THINGS (Programmable Wireless).