Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
MMS Delivery Delays for a Subset of US Twilio Short Codes
Incident Report for Twilio
Resolved
We are no longer experiencing delivery delays for MMS on a subset of US Twilio short codes. This incident has been resolved.
Posted Sep 28, 2020 - 21:05 PDT
Update
We are observing recovery in delivery delays for MMS on a subset of US Twilio short codes. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Sep 28, 2020 - 19:49 PDT
Monitoring
We are observing recovery in delivery delays for MMS on a subset of US Twilio short codes. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Sep 28, 2020 - 15:52 PDT
Update
We are experiencing MMS delivery delays from a subset of Twilio US short code numbers. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 2 or as soon as more information becomes available.
Posted Sep 28, 2020 - 14:20 PDT
Update
We are experiencing MMS delivery delays from a subset of Twilio US short code numbers. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 or as soon as more information becomes available.
Posted Sep 28, 2020 - 12:59 PDT
Investigating
Our monitoring systems have detected a potential MMS delivery delay issue for a subset of Twilio US short code numbers. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Sep 28, 2020 - 12:45 PDT
This incident affected: CARRIER NETWORK (MMS Short Code, North America, SMS Delivery Notifications & Status Callbacks).