Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Black Friday / Cyber Monday Alert
      Incident Report for Twilio
      Resolved
      The issue affecting traffic on US and Canada networks has been resolved, and the service is functioning normally at this time.
      Posted Nov 28, 2022 - 19:00 PST
      Investigating
      Due to increased traffic demand on mobile communication networks, we are expecting potential congestion for US carrier networks during the Black Friday and Cyber Monday period. Customers may experience intermittent SMS and MMS delivery delays. Please refer to our Black Friday / Cyber Monday FAQ page at https://support.twilio.com/hc/en-us/articles/4411075931163-Notice-Potential-Message-Delays-During-the-Midterm-Elections-Black-Friday-Cyber-Monday-2022 for more information.
      Posted Nov 24, 2022 - 17:36 PST