Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays to a Subset of small US Networks
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS delivery delays when sending messages to a Subset of small US Networks. This incident has been resolved.
      Posted Jun 20, 2024 - 11:16 PDT
      Monitoring
      We are observing recovery in the SMS delivery times when sending messages to a Subset of small US Networks. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Jun 20, 2024 - 09:30 PDT
      Update
      We are still experiencing SMS delivery delays when sending messages to a Subset of small US Networks. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Jun 20, 2024 - 07:48 PDT
      Update
      We are experiencing SMS delivery delays when sending messages to a Subset of small US Networks. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 or as soon as more information becomes available.
      Posted Jun 20, 2024 - 06:57 PDT
      Investigating
      We are experiencing SMS delivery delays when sending messages to a Subset of small US Networks. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 or as soon as more information becomes available.
      Posted Jun 20, 2024 - 06:55 PDT
      This incident affected: CARRIER NETWORK (SMS Short Code, North America) and PROGRAMMABLE MESSAGING (SMS).