Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS delivery status delays to Indosat Indonesia
Incident Report for Twilio
Resolved
We are no longer experiencing delays in receiving the delivery status of messages to the Indosat network in Indonesia. This incident has been resolved.
Posted May 15, 2020 - 11:47 PDT
Update
We are still observing delays in the delivery status of messages to the Indosat network in Indonesia. We continue working with our carrier partners to resolve the issue and will provide an update as soon as we have more information.
Posted May 15, 2020 - 07:57 PDT
Update
We are continuing to investigate the issue and will provide an update as soon as we have more information.
Posted May 15, 2020 - 05:04 PDT
Update
We are continuing to investigate the issue and will provide an update as soon as we have more information.
Posted May 14, 2020 - 23:58 PDT
Update
We are still observing delays in the delivery status of messages to the Indosat network in Indonesia. We are working with our carrier partners to resolve the issue and will provide an update as soon as we have more information.
Posted May 14, 2020 - 19:25 PDT
Update
We are still observing delays in the delivery status of messages to the Indosat network in Indonesia. The actual SMS delivery is not impacted. We are working with our carrier partners to resolve the issue and will provide an update as soon as we have more information.
Posted May 14, 2020 - 17:01 PDT
Investigating
We are observing delays in receiving the delivery status of messages to the Indosat network in Indonesia. We are working with our carrier partners to resolve the issue and will provide an update as soon as we have more information
Posted May 14, 2020 - 16:05 PDT
This incident affected: CARRIER NETWORK (SMS, APAC).