Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays to Zimbabwe Netone
      Incident Report for Twilio
      Resolved
      We are no longer experiencing delivery delays when sending messages to the Netone network in Zimbabwe. This incident has been resolved.
      Posted May 14, 2020 - 08:08 PDT
      Monitoring
      We are observing successful delivery when sending messages to the Netone network in Zimbabwe. We will continue to monitor to ensure a full recovery.
      Posted May 14, 2020 - 07:46 PDT
      Investigating
      We are experiencing SMS delivery delays when sending messages to the Netone network in Zimbabwe. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
      Posted May 14, 2020 - 04:38 PDT