Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Inbound Toll-Free SMS Delays from Verizon handsets
Incident Report for Twilio
Resolved
All services are operating normally.
Posted 17 days ago. Jan 03, 2019 - 08:42 PST
Monitoring
Our carrier partner has identified and corrected the issue. We are now observing full recovery for inbound SMS and Delivery Receipts sent from Verizon subscribers to Twilio US Toll-Free numbers. Our teams will continue to monitor.
Posted 17 days ago. Jan 03, 2019 - 08:19 PST
Investigating
We are observing inbound delivery delays for SMS and Delivery receipts (DLRs) sent from Verizon subscribers to Twilio US Toll-Free numbers. Outbound messages sent to Verizon subscribers are not affected. We are working with our carrier partners to resolve the issue and will provide an update as soon as we have more information.
Posted 17 days ago. Jan 03, 2019 - 08:02 PST
This incident affected: PROGRAMMABLE MESSAGING (SMS).