Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Super SIM connectivity issue
Incident Report for Twilio
Resolved
Super SIM connectivity issues have been resolved and Super SIM is operating normally at this time.
Posted Nov 12, 2020 - 02:58 PST
Monitoring
We are now seeing recovery of the network connectivity issue. We are continuing to monitor for service stability. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Nov 12, 2020 - 01:36 PST
Update
We are experiencing Super SIM connectivity issues. Some devices may have experienced resets in data sessions. Newly established data sessions should not be affected. Our engineering team is actively working with the affected network provider to resolve the issue. We will provide another update in 1 hour or as soon as more information
Posted Nov 12, 2020 - 00:28 PST
Investigating
Our monitoring systems have detected a potential issue with Super SIM. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Nov 12, 2020 - 00:15 PST
This incident affected: INTERNET OF THINGS (Super SIM).