Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Flex Insights (Flex WFO) Dashboards are currently unavailable
Incident Report for Twilio
Resolved
This incident has been resolved.
Posted Oct 30, 2019 - 19:38 PDT
Update
We are continuing to investigate this issue.
Posted Oct 30, 2019 - 19:37 PDT
Investigating
The Flex Insights (Flex WFO) dashboards are currently unavailable as our downstream dashboard visualization partner is down. Our engineers are working with them to restore service as soon as possible. We currently do not have an ETA for resolution. We will provide the next update within 4 hours.
Posted Oct 30, 2019 - 18:42 PDT
This incident affected: CONTACT CENTER (Flex WFO).