Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 25, 2026 - 02:00 PDT
Update
The Flex Insights Historical Reporting dashboard visualization partner in the US will be conducting planned maintenance on from 07/25/26 at 2:00 AM to 5:00 AM Pacific Daylight Time. The maintenance window is expected to last up to 3 hours. During this time, Flex Insights Historical Reporting Dashboards will be unavailable and scheduled ETLs will be affected.
Posted Jul 24, 2026 - 07:23 PDT
Scheduled
The Flex Insights Historical Reporting dashboard visualization partner in the US will be conducting planned maintenance on from 07/25/26 at 2:00 AM to 5:00 AM Pacific Daylight Time. The maintenance window is expected to last up to 3 hours. During this time, Flex Insights Historical Reporting Dashboards will be unavailable and scheduled ETLs will be affected.
Posted Jul 23, 2026 - 23:31 PDT
This scheduled maintenance affected: FLEX (Flex Insights).