Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Outbound SMS Delays to T-Mobile & MetroPCS from US short codes
Incident Report for Twilio
Resolved
The issue causing SMS Delivery delays to T-Mobile and MetroPCS handsets is now resolved and we are observing full and stable recovery.
Posted 3 months ago. Dec 14, 2018 - 09:08 PST
Monitoring
We are observing full and stable recovery for SMS delivery to T-Mobile and MetrocPCS handsets from US short codes. Our engineering teams will continue to monitor the service.
Posted 3 months ago. Dec 14, 2018 - 08:50 PST
Investigating
We are experiencing delays sending SMS from a subset of US short codes to T-Mobile and MetroPCS handsets. Inbound delivery and long code traffic is not affected. Our engineering team is actively working with our partner to get the issue resolved. We will provide an update as soon as possible.
Posted 3 months ago. Dec 14, 2018 - 08:36 PST
This incident affected: CARRIER NETWORK (SMS Short Code, North America) and PROGRAMMABLE MESSAGING (SMS).