Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Delays to UK
Incident Report for Twilio
Resolved
Between 16:15 and 19:30 GMT approximately 50% of SMS messages were delayed for up to 30 minutes. We have confirmed recovery of the service.
Posted 3 months ago. Apr 08, 2019 - 12:41 PDT
Update
We are continuing to monitor for any further issues.
Posted 3 months ago. Apr 08, 2019 - 12:29 PDT
Update
We are continuing to monitor for any further issues.
Posted 3 months ago. Apr 08, 2019 - 12:28 PDT
Monitoring
We have detected a period of SMS delivery delays to UK destinations. The cause of the delays has been identified and we have observed recovery. We will continue to monitor performance at this time.
Posted 3 months ago. Apr 08, 2019 - 12:10 PDT
This incident affected: CARRIER NETWORK (SMS, Europe) and PROGRAMMABLE MESSAGING (SMS).