Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays From and To All Networks In South Africa Over A Subset of Domestic Longcodes
      Incident Report for Twilio
      Resolved
      We are no longer experiencing MMS/SMS delivery delays from and to all networks In South Africa. This incident has been resolved.
      Posted Mar 08, 2023 - 06:23 PST
      Update
      We are observing recovery in MMS/SMS delivery delays from and to all networks In South Africa. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Mar 08, 2023 - 04:37 PST
      Monitoring
      We are observing recovery in MMS/SMS delivery delays from and to all networks In South Africa. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Mar 08, 2023 - 02:39 PST
      Update
      We are experiencing an inbound message delivery delays to Twilio Long code number in South Africa. Customers may experience latency in receiving SMS messages from various mobile networks in South Africa. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 4 hour or as soon as more information becomes available.
      Posted Mar 08, 2023 - 01:04 PST
      Update
      We continue to experience inbound message delivery delays to all networks In South Africa over a subset of domestic long code numbers. Customers may experience latency in receiving SMS messages from various mobile networks in South Africa. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Mar 07, 2023 - 23:01 PST
      Investigating
      We are experiencing an inbound message delivery delays to Twilio Long code number in South Africa. Customers may experience latency in receiving SMS messages from various mobile networks in South Africa. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Mar 07, 2023 - 22:01 PST
      This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).