Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Sign up Failing for New Customers
      Incident Report for Twilio
      Resolved
      Sign up failing for new customers has been resolved and Twilio Console is operating normally at this time.
      Posted Nov 24, 2020 - 10:22 PST
      Monitoring
      Sign up is now operating normally. We will continue to monitor the situation before we mark the incident as fully resolved. We expect to provide another update in 30 minutes or as soon as more information becomes available.
      Posted Nov 24, 2020 - 10:01 PST
      Investigating
      Sign up is currently down for new customers. Our Engineers are working to resolve the issue. We expect to provide another update in 1 hour.
      Posted Nov 24, 2020 - 09:19 PST
      This incident affected: DEVELOPER TOOLS (Console).