Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      MMS Delivery Report Delays From a Subset of Shortcodes to Multiple Networks in US
      Incident Report for Twilio
      Resolved
      We are no longer experiencing MMS delivery report delays when sending from a subset Twilio short codes to multiple networks in the US. This incident has been resolved.
      Posted Jan 13, 2023 - 20:07 PST
      Update
      We are observing recovery in MMS delivery report delays when sending from a subset Twilio short codes to multiple networks in the US. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Jan 13, 2023 - 19:19 PST
      Monitoring
      We are observing recovery in MMS delivery report delays when sending from a subset Twilio short codes to multiple networks in the US. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Jan 13, 2023 - 17:19 PST
      Update
      We are still observing delays in receiving MMS delivery reports to multiple networks in USA from a subset of short codes. Our engineering team has been alerted and is actively investigating. We will update in the next 4 hours or as soon as we have more information.
      Posted Jan 13, 2023 - 13:21 PST
      Update
      We are still observing delay in receiving MMS delivery reports to multiple networks in USA from a sub-set of short code. Our engineering team has been alerted and is actively investigating. We will update in the next 2 hours or as soon as we have more information.
      Posted Jan 13, 2023 - 11:19 PST
      Investigating
      We are observing delay in receiving MMS delivery reports to multiple networks in USA from a sub-set of short code. Our engineering team has been alerted and is actively investigating. We will update in the next 1 hour or as soon as we have more information.
      Posted Jan 13, 2023 - 10:21 PST
      This incident affected: CARRIER NETWORK (SMS Delivery Notifications & Status Callbacks, MMS Delivery Notifications & Status Callbacks).