Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays to MTN Network in Yemen
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS delivery delays when sending messages to MTN Network in Yemen. This incident has been resolved.
      Posted Oct 07, 2021 - 01:01 PDT
      Monitoring
      We are observing recovery in SMS delivery delays when sending messages to the MTN Network in Yemen. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Oct 06, 2021 - 23:20 PDT
      Update
      We are experiencing SMS delivery delays to the MTN Network in Yemen. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 4 hours or as soon as more information becomes available.
      Posted Oct 06, 2021 - 23:10 PDT
      Update
      We are experiencing SMS delivery delays to the MTN Network in Yemen. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
      Posted Oct 06, 2021 - 21:05 PDT
      Investigating
      We are experiencing SMS delivery delays to the MTN Network in Yemen. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Oct 06, 2021 - 20:05 PDT