Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Inbound calls to Spanish numbers failing
      Incident Report for Twilio
      Resolved
      We are no longer experiencing delivery failures for inbound calls toward a subset of our numbers in Spain. This incident has been resolved.
      Posted May 13, 2020 - 10:46 PDT
      Investigating
      We are experiencing failures for inbound calls toward a subset of our numbers in Spain. Our engineers are investigating the case with the underlying carriers. We will provide more information as soon as it becomes available.
      Posted May 13, 2020 - 08:40 PDT
      This incident affected: CARRIER NETWORK (Voice, Europe).