Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Delays in sending messages from US Toll-Free numbers
Incident Report for Twilio
Resolved
This issue has been resolved. All services are operating normally.
Posted 9 months ago. Apr 30, 2018 - 18:09 PDT
Update
SMS delivery on all carriers has recovered. The remaining issue is delays on DLRs for all carriers.
Posted 9 months ago. Apr 30, 2018 - 15:33 PDT
Update
SMS delivery on T-Mobile has recovered for new messages. The remaining issues are delays in previously queued messages on T-Mobile and delays on DLRs for all carriers.
Posted 9 months ago. Apr 30, 2018 - 13:43 PDT
Update
Our carrier continues to work to resolve the issue. We will update again when we are able to observe recovery.
Posted 9 months ago. Apr 30, 2018 - 11:51 PDT
Update
SMS delivery on AT&T & Verizon has recovered. The remaining issues are DLR delays for all messages and SMS delivery delays on T-Mobile only.
Posted 9 months ago. Apr 30, 2018 - 09:58 PDT
Monitoring
We are observing recovery. Queued messages are being processed. We will post an update when delivery has been fully recovered.
Posted 9 months ago. Apr 30, 2018 - 08:48 PDT
Update
We continue to see delays for sending messages from US Toll-Free numbers to AT&T & T-Mobile. We have also detected delays for sending messages from US Toll-Free numbers to Verizon. Our carrier partner is actively working to resolve the issue.
Posted 9 months ago. Apr 30, 2018 - 08:29 PDT
Investigating
We have detected delays for sending messages from US Toll-Free numbers to AT&T & T-Mobile. We have escalated to the carrier and they are actively working to resolve the issue.
Posted 9 months ago. Apr 30, 2018 - 07:54 PDT
This incident affected: PROGRAMMABLE MESSAGING (SMS).